Global internet outage

Incident Report for Zip

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 11:27 EST

Monitoring

A fix has been implemented by Cloudflare and we are seeing full recovery on our systems. We are continuing to monitor.
Posted Nov 18, 2025 - 09:52 EST

Investigating

Cloudflare is currently experiencing a global network outage as of 12:03 UTC on 18 Nov 2025. This incident is impacting some Zip services, which may be partially unavailable or degraded.
Our team is actively working to mitigate the impact and restore full functionality. We will provide further updates as more information becomes available.
Posted Nov 18, 2025 - 08:16 EST
This incident affected: Checkout, Mobile App, Customer Portal, Merchant Portal and APIs (Gateway API, Virtual Checkout API, Legacy API).