Intermittent DNS Outage

Incident Report for Zip

Resolved

This incident has been resolved.
Posted Apr 18, 2026 - 10:09 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 18, 2026 - 10:07 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 17, 2026 - 18:34 EDT

Monitoring

We’re currently aware of an intermittent DNS issue affecting parts of the internet across the U.S., which is unrelated to Zip.

If you’re experiencing issues with our website or parts of the Zip Mobile App not loading or functioning properly, we recommend switching off WiFi and using your cellular network, as this may resolve the issue.

DNS-related issues can take several hours to fully resolve across networks, and in some cases may take up to 24 hours.
Posted Apr 17, 2026 - 18:04 EDT
This incident affected: Mobile App, Customer Portal, and Merchant Portal.